最近一个更新版本后 Rhino 6 的make2d和注解显示有严重的bug


#1


就比如这么简单的模型,都会有线不能被正确地生成,而且这还不是孤例。

这个模型顶上的洞也不能被正确地生成。

而且在一个场景中进行过一次make2d之后,进行第二次make2d就只生成前视图的投影线条了。

注解文字有时候会在更改注解样式后莫名其妙地消失,撤销操作都没有用只能重新打开文件。

这些bug还是很严重的,导致我现在只能回rhino 5 进行 make2d 的操作。只是在最后一次更新后有这样的问题,之前不存在这个bug。


#2

Hi 您好

可否將您的Rhino 6 說明下的系統資訊資料提供給我們? 我想確認您使用的版本做測試。 謝謝!


#3

你好,你指的是systeminfo命令的信息吗,我粘贴在下面了。

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Educational, 版本2018-11-07
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-SI9TJFC

Quadro M1000M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.82)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-30-2018
Driver Version: 24.21.13.9882
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


#4

@blue141, 可以請你附上這個模型檔案嗎? 不放便公開請用私訊,謝謝。


#5

bugreport.3dm (111.1 KB)

该文件在我的电脑上make2d的效果如图


#6

我試了你的模型檔案,打開檔案,還原作業視窗為四個作業視窗,再把 Perspective 作業視窗最大化,再做一次 Make2D 就正常了。SR9、SR10、內部版本 SR12 都有同樣的問題,我已經報給我們的工程師修正了,謝謝。
https://mcneel.myjetbrains.com/youtrack/issue/RH-49746


#7

谢谢!按照你的方法问题解决了。