Rhino和Autocad 测量兼容与其他问题


#1

@kelvinc @Jessesn @Yoko

Rhino:Unit Rhino vs Autocad.3dm (156.6 KB)

Autocad: Test 1.dwg (16.3 KB)

问题一, 如图所示,Rhino能否把数字位置从A移到B位置? 好像没有这个设定,我只能炸开它们,只能手动移动文字。

问题二,
Rhino里的单位设置如下:
Model unit : Feet
Layout unit: inch

Autocad 单位
Model : Feet
Layout: Inch

Rhino 导出dwg后导进Autocad,出现错误测量问题。 我查了下单位设置,Autocad成功克隆了Rhino单位设置,但是测量数字缩小了。 一个是 4’多 一个才4“多,相差太多。请测试。


#2

你可以按 F10 打開控制點就可以移動文字,不必炸開。

我要安裝 AutoCAD 看看才知道是什麼情形…


#3

多谢~~


#4

@KelvinC

这个测量问题往美国那边发了,没答复。 只有你出马才快,哈哈。


#5

這個是 Dimension style 的 Number/Unit Format 的問題,不是 Model/Layout Unit 的問題。

尺寸是一樣的,只是顯示的方式不一樣,或許你可以問問 Autodesk 能不能把它設的和 Rhino 一樣。


#6

@KelvinC

明白了。 Mcneel有你这样的队友,的确有福啊。 :+1:

太离谱了,你看到没有 实际长度是11‘-1/2", 测量结果是 0’-xx开头。


#7

@KelvinC
改这个解决了问题。 不理解为什么整这样的设置。 既然units设置都一样。


#8

這個我要問問寫 dwg exporter 的工程師看看。


#9

@KelvinC

对了 还有个问题就是 Rhino里的Dimstyle怎么保存? 做temple 文件还是…???
或者最好的方法保存


#10

和 Hatch Pattern 一樣,儲存在 template 裡,或按 Import,從其它的 3dm 匯入。


#11

以下是我們的工程師的回答:

I think the problem is from exporting a Rhino model with units=feet to Acad, where units are not explicit and setting display to Feet-Inches causes units to be treated as inches.
So 3’-2" inches (3.167 feet) in Rhino becomes 3-1/4" (3.167 inches) in Acad.
In the US, its most common to use units=inch for all Architectural drawing, which is probably why this hasn’t been a big complaint.
I think it would be good to add an option in to the dwg exporter to scale by 12 if units are feet in Rhino.
Here, civil engineering drawings (site plans, road work, etc) are typically done in foot units and dimensioned in decimal feet, not feet and inches. In that case, it would be wrong to scale by 12 on export.

What is the context of your report? Is there a user complaint? If there was, what was the workflow?


#12

@KelvinC

对,就是那样。应该用inch单位。 unit改成inch没有问题。这个问题完全解决了。 Rhino和Autocad结合非常完美。layout都能克隆的没有缺陷。 其实,多加一个选项 scale 12 感觉有点多余。因为Autocad里设置建筑单位时,用feet单位会出现警告窗口。 直接在Rhino里改成inch后导出就行。 Rhino很牛 :+1:
多谢多谢~~